funcao-indice-corresp-no-excel-0

O Que é a Função ÍNDICE e CORRESP

Já notou que a função PROCV tem algumas limitações? Embora o  PROCV dê conta do recado na maioria dos casos, existem situações onde ele sozinho não resolve o problema. E é aí que entra a fórmula que combina as funções  ÍNDICECORRESP.

Essa combinação cria uma fórmula do tipo Procura e Referência, que é capaz de retornar resultados inclusive de células à esquerda da coluna onde efetuamos uma busca. O que não é possível com a PROCV, que só consegue mostrar valores de células à direita da coluna da busca.

Quando Utilizar as Funções ÍNDICE e CORRESP Juntas?

Utilize a combinação das funções ÍNDICE e CORRESP quando houver a necessidade de retornar como resultado valores contidos em colunas à esquerda da coluna onde está se efetuando a busca.

Bom, primeiro vou explicar o funcionamento de cada uma das funções separadamente, usando a tabela abaixo como exemplo.

Função ÍNDICE

Retorna o valor da célula na interseção de uma linha com uma coluna em um dado intervalo de células.

Essa é sua sintaxe: ÍNDICE(matriz; núm_linha; [núm_coluna])

  • matriz. Obrigatório. Um intervalo de células ou uma constante de matriz.
  • Núm_linha. Obrigatório. Seleciona a linha na matriz a partir da qual um valor deverá ser retornado. Se Núm_linha for omitido, Núm_coluna é obrigatório.
  • Núm_coluna. Opcional. Seleciona a coluna na matriz a partir da qual um valor deverá ser retornado. Se Núm_coluna for omitido, Núm_linha é obrigatório.

funcao-índice-corresp-no-excel-1

Para a tabela acima, escrevendo a fórmula =ÍNDICE(A1:D5;2;3), obteremos como resultado o valor 31, correspondente a interseção da linha 2 com a coluna 3 dentro do intervalo A1:D5.

Função CORRESP

Retorna a posição de um item em uma determinada coluna.

Essa é sua sintaxe: CORRESP(valor_proc; matriz_proc; [tipo_corresp])

  • valor_proc. Obrigatório. O valor que deseja fazer corresponder com matriz_proc.
  • matriz_proc. Obrigatório. O intervalo de células onde a pesquisa é efetuada.
  • tipo_corresp. Opcional. O número -1, 0 ou 1. O argumento tipo_corresp especifica a forma como o Excel faz corresponder valor_proc aos valores contidos em matriz_proc.

funcao-índice-corresp-no-excel-1

Para a tabela acima, escrevendo a função =CORRESP(“Débora”;B:B;0), o Excel mostrará o valor 4, correspondente a posição do nome Débora na coluna B.

Unindo as Funções ÍNDICE e CORRESP

Os argumentos da função ÍNDICE núm_linha e [núm_coluna]  representam a posição de um dado em células organizadas em uma mesma linha, ou em uma mesma coluna, ou seja, justamente o que a função CORRESP faz. Assim podemos incluir o CORRESP nestes argumentos do ÍNDICE.

Primeiro Exemplo De Uso De ÍNDICE + CORRESP

Utilizando a mesma tabela com os dados fictícios dos países do Mercosul, digamos que queiramos agora, encontrar o Dado 2 referente ao Paraguai.

Nossa fórmula deve ser assim:

=ÍNDICE(matriz; CORRESP(valor_procurado; matriz_procurada; [tipo_correspondência]); CORRESP(valor_procurado; matriz_procurada; [tipo_correspondência]))

funcao-índice-corresp-no-excel-2

Assim nossa fórmula ficou:

VERDE PARA ÍNDICE

VERMELHO PARA O 1º CORRESP

AZUL PARA O 2º CORRESP

matriz → C7:F11 = Área onde estão os dados na tabela.

núm_linha → 1ª Função Corresp

valor_procurado → D2 = Célula onde está o nome do país que queremos a informação.

matriz_procurada → B7:B11 = Intervalo onde estão os dados com o nome dos países.

[tipo_correspondência] → 0 (zero), pois é o valor que indica a função que queremos uma correspondência exata, ou seja, queremos procurar exatamente pela posição do Paraguai.

[núm_coluna] → 2ª Função Corresp

valor_procurado → D3 = Célula onde está o nome do indicador que queremos a informação.

matriz_procurada → C6:F6 = Intervalo onde estão os nomes dos indicadores.

[tipo_correspondência] → 0 (zero), pois é o valor que indica a função que queremos uma correspondência exata, ou seja, queremos procurar exatamente pela posição do Dado 2.

O primeiro CORRESP deve retornar o número 3, pois contando a partir da célula B7 o Paraguai está na 3ª posição.

Já o segundo CORRESP deve retornar o número 2, pois contando a partir da célula C6 o Dado 2 está na 2ª posição.

Em outras palavras, o que pedimos para essa fórmula fazer foi: No intervalo de C7:F11 me retorne o dado que estiver na mesma linha (posição vertical) que Paraguai está no intervalo B7:B11 e também na mesma coluna (posição horizontal) que Dado 3 está no intervalo C6:F6. Ou seja, o dado que estiver no intervalo C7:F11 na 3ª linha e 2ª coluna.

Então, nossa fórmula combinada de ÍNDICE e CORRESP deve retorna o valor 696 pois é o indicador Dado 2 referente ao Paraguai.

Segundo Exemplo De Uso De ÍNDICE + CORRESP

Iremos agora buscar os dados que estão na coluna mais a esquerda de uma tabela, como dito anteriormente, algo que o PROCV sozinho não consegue fazer, já que ele sempre busca da esquerda para a direita.

A tabela abaixo contém alguns dados sobre a população dos países do BRICS e queremos descobrir qual dos países tem o percentual de população feminina igual a 48,29%.

funcao-índice-corresp-no-excel-3

Neste caso não precisaremos utilizar dois CORRESP dentro do ÍNDICE, mas apenas um. Isso porque a única informação que precisaremos obter com ajuda do CORRESP é a linha em quem o dado está, uma vez que já definimos qual o indicador a ser utilizado e em qual coluna ele estará.

Veja a seguir como fica essa fórmula.

funcao-índice-corresp-no-excel-4

VERDE PARA ÍNDICE

VERMELHO PARA O CORRESP

matriz → B6:B10 = Área onde estão os dados com os nomes dos países.

núm_linha → Função CORRESP

valor_procurado → C2 = Célula onde está o valor do indicador que queremos a informação.

matriz_procurada → F6:F10 = Intervalo onde estão os dados do indicador desejado.

[tipo_correspondência] → 0 (zero), pois é o valor que indica a função que queremos uma correspondência exata.

[núm_coluna] → Não aparece na função. Se trata de um dado opcional e desnecessário neste caso, já que a área que selecionamos em matriz possui somente uma coluna. Deixar esse argumento em branco ou com o valor 1, dá na mesma.

O que dissemos para esta fórmula fazer foi: No intervalo de B6:B10 retorne o dado que estiver na mesma posição que o valor 48,29% está no intervalo de F6:F10. Ou seja retorne o dado que estiver na 3ª posição no intervalo de B6:B10.

O resultado dessa fórmula deve retornar Índia, pois é o país com 48,29% de população feminina.

Veja Também

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *