Funça~PROCV no Excel

O Que é a Função PROCV?

Considerada uma das fórmulas mais utilizadas nas empresas, a função PROCV compara e/ou encontra informações dentro de uma tabela, é uma função de procura de dados organizados na vertical. O nome da fórmula é originário de suas iniciais como “PROC” de procurar e “V” de vertical.

Em sua forma mais simples, a função PROCV diz:

=PROCV(Valor que você deseja pesquisar; intervalo no qual você deseja pesquisar o valor; o número da coluna no intervalo contendo o valor de retorno; Correspondência Exata ou Correspondência Aproximada – indicado como 0/FALSO ou 1/VERDADEIRO).

  • valor_procurado: esse item da função =PROCV() é o valor que deve ser localizado na primeira coluna da tabela. Desta forma, você poderá digitar esse valor ou indicar a referência da célula do mesmo;
  • matriz_tabela: se refere a tabela onde deve ser encontrado o valor procurado e as informações referentes ao mesmo. Esta tabela pode ter duas ou mais colunas e estar situada em outra planilha do mesmo documento;
  • núm_indice_coluna: esse item corresponde ao número da coluna da tabela, indicada no item matriz_tabela, em que deve ser retornado o valor correspondente ao valor procurado;
  • procurar_intervalo: esse item pode ter dois valores: VERDADEIRO ou FALSO. Se você colocar FALSO, a função só encontrará um valor exatamente igual ao informado no item valor_procurado. Se você colocar VERDADEIRO, a função poderá encontrar um valor que não seja exatamente igual, mas que tenha apenas um valor aproximado ao informado no item valor_procurado.

Como Funciona a Função PROCV.

Para entender o que a fórmula PROCV no Excel faz, imagine-se em um supermercado.

Ao comprar um produto, o operador de caixa passa o código de barras do produto no caixa e na tela do computador surgem diversas informações como: NOME DO PRODUTO, PREÇO, etc.

Neste simples exemplo está acontecendo a fórmula PROCV, pois o computador está procurando a informação do CÓDIGO DE BARRAS em um banco de dados armazenado dentro do computador do caixa e puxando as informações necessárias.

A primeira tabela consiste nos produtos que você tem em seu “Carrinho de Compras”. A segunda tabela é o “Banco de dados do Supermercado”.

Agora vamos pensar o que o computador faz para puxar a informação do NOME DO PRODUTO:

  • Ao passar um produto no caixa, o computador irá ler o CÓDIGO DE BARRAS (valor procurado);
  • Depois, ele vai procurar este CÓDIGO lá no BANCO DE DADOS DO SUPERMERCADO (matriz tabela);
  • Depois que ele encontrar o código de barras nessa tabela, ele irá buscar a informação que está na coluna ao lado (num_índice_coluna), que é o NOME DO PRODUTO.

Este é exatamente o mesmo passo que o Excel faz, e é exatamente os parâmetros que você deve informar na fórmula!

Como Utilizar a Função PROCV

Para entender melhor o funcionamento da PROCV, crie uma tabela com o nome “Produtos” e coloque os dados de alguns produtos, como no exemplo abaixo.

Função PROCV no Excel -1
Criando uma tabela de produtos no Excel

Em seguida, crie outra tabela chamada “Vendas” com três colunas. A primeira vai se chamar “Fatura” e servirá para guardar o código da venda, a outra chamada “Produto” servirá para digitar o código do produto, e finalmente a coluna “Descrição” será usada para colocar a fórmula que buscará o nome do produto para ser exibido.

Em seguida, preencha o campo “Descrição” com o seguinte conteúdo:

=PROCV($B2;Produtos!$A$2:$C$6;2;FALSO)

Função PROCV no Excel -2
Colocando a formula PROCV no campo “Descrição” da tabela “Vendas”

A seguir, clique no campo preenchido e arraste o cursor até a última linha para copiar a fórmula para o resto da planilha.

Pronto. Agora, sempre que você digitar um dos códigos da tabela “Produtos” no campo “Produto” da tabela “Vendas”, o campo “Descrição” será preenchido automaticamente com o “Nome” correspondente ao código.

Função PROCV no Excel -4
Tabela vendas exibindo a informação encontrada pela função PROCV

Principais Aplicações

Como visto no exemplo acima, a função PROCV pode ser usada para interligar informações de tabelas, evitando a duplicidade de dados e erros de digitação. Isso é muito importante porque esses problemas são uma ocorrência comum na utilização de planilhas, principalmente quando a quantidade de dados cresce muito.

Usar a função PROCV no Excel ajuda em uma funcionalidade básica de banco de dados que pode muito bem colaborar na organização de pequenas quantidades de dados para torná-los mais úteis.

Veja Também

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *