Função INDIRETO no Excel

O que a Função INDIRETO Faz?

A função INDIRETO permite que você tenha opções mais dinâmicas ao trabalhar com suas planilhas. De forma resumida, ela usa como referência o valor de outra célula para efetuar um cálculo. É como se ela criasse um “atalho” para acessar algum valor.

A função INDIRETO tem por finalidade trazer as informações contidas em um intervalo referenciado por um endereço escrito em outra célula. Exemplo, se tivermos um endereço digitado em uma célula e você quiser saber qual o valor que possui este endereço.

Na função INDIRETO você pode tanto utilizar endereços definidos utilizando listas de validação de dados para trazer informações destes, pode montar a informação com dados concatenados ou simplesmente referenciar uma célula que contém um endereço.

A sintaxe da fórmula indireto é muito simples:

=INDIRETO(texto_ref;a1), sendo:

texto_ref: A célula em que consta o endereço que deverá retornar o valor;

a1: Você pode informar 1 que é o padrão ou 0. O tipo 1 significa que a referência contém informações de endereço do tipo A1, para 0 significaria que a referência contém informações do tipo L1C1.

Aplicações Práticas da Fórmula Indireto

A função INDIRETO existe para facilitar a sua vida em algumas situações. A principal delas é quando você tem uma planilha de controle com um item e você precisa buscar suas características em planilhas diferentes.

Por exemplo, vamos supor que você queira criar uma planilha para controlar seus gastos pessoais. Nesta planilha você vai ter uma planilha para cada mês do ano e uma planilha principal com análises do mês que você escolheu. Uma forma de fazer isso, seria utilizando funções condicionais, mas imagina o trabalho que daria fazer um “SE” para cada mês… Vamos montar a planilha desta forma:

Função-INDIRETO-2

Reparem que a planilha tem um campo para escolher o mês que será analisado, uma lista de meses (apenas para fazer uma lista suspensa) e planilhas para cada mês. Ao criar a lista suspensa, através da validação de dados, o campo de escolha de mês passa a ter um menu para o usuário escolher o mês que ele quer analisar.

Imagine que você precisa do valor da célula A1 do mês escolhido na planilha do mesmo. Caso você fosse buscar dados nas planilhas usando Condicionais, você teria que usar uma função parecida com essa: =SE(L3=”Janeiro”;Janeiro!A1;SE(L3=”Fevereiro”;Fevereiro!A1;SE(L3=”Março”;……). Esta fórmula se estenderia para todos os meses.

Utilizando a função INDIRETO, você só precisa disso: =INDIRETO(E3&”!A1″). Como o Excel lê isso? E3 é uma célula, por não estar entre aspas, portanto ele lê o valor da célula E3 – Janeiro. “!A1” é uma referência de texto, por estar entre aspas. & é um termo usado para unir as duas partes. Ou seja, ele lê Janeiro!A1 – Planilha Janeiro, célula A1.

Vamos fazer um teste:

  1. Escreva na planilha Janeiro, célula A1 “Primeiro Mês do Ano”
  2. Escreva na planilha Fevereiro, célula A1 “Segundo Mês do Ano”.
  3. Depois Escreva a fórmula =INDIRETO(E3&”!A1″)” na célula E7 da planilha Principal
  4. Preencha a célula E3 da planilha Principal com “Janeiro”. A célula E7 deve mostrar o texto “Primeiro Mês do Ano”
  5. Troque o conteúdo da célula E3 para “Fevereiro”. O conteúdo da célula E7 deve ter trocado para “Segundo Mês do Ano”

Veja as imagens abaixo:

Função-INDIRETO-3

Função-INDIRETO-4

Função-INDIRETO-5

Há ainda a possibilidade de utilizar a fórmula INDIRETO dentro de uma fórmula PROCV ou PROCH. Vamos testar um exemplo disso:

  1. Das linhas 10 a 19 na planilha Principal, na coluna A, escreva os algarismos 1 a 10.
  2. Faça o mesmo na planilha Janeiro.
  3. Nas linhas 10 a 19 na planilha Janeiro, na coluna B, escreva valores aleatórios como na imagem abaixo:Função-INDIRETO-6
  4. Na planilha Principal, na célula B10, escreva a fórmula =PROCV(A10;INDIRETO(“$E$3″&”!A10:B19″);2;FALSO).
  5. Arraste esta fórmula para as linhas B11 a B19 na planilha Principal.
  6. Pronto! Você tem agora a mesma tabela nas duas planilhas. O Excel leu o conteúdo da fórmula INDIRETO como Janeiro!A10:B19, exatamente o que você colocaria na matriz do PROCV se não tivesse a fórmula.

Se você preencher todas as planilhas com conteúdo semelhante, utilizando a fórmula INDIRETO você poderá criar um excelente painel na planilha Principal. Trocando o mês na célula E3, seu painel importará os dados do mês escolhido na célula correta.

Espero que a fórmula INDIRETO te ajude muito daqui para a frente!

Veja Também

1 thought on “Função INDIRETO no Excel

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *